We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

xenserver problema com rescue pro


ricardo.durao
12-07-12, 17:02
Boa tarde,

Sim, de facto o kpartx é o que se deve utilizar, uma vez que, pelo que verifico, existem duas formas de montar imagens LVM. Depende das partições e pelo que sei existem as 'not lvm partitioned' e as 'lvm format' e neste último caso, não é possível utilizar então os normais comandos de "montagem" das partições/discos.

No caso do XenServer, o normal é a utilização do LVM format, daí ser necessário a utilização do kpartx. Como indicado por si, e corretamente, não o teríamos instalado no modo de rescue. Após uns pequenos testes e após confirmação que não se conseguia a 100% montar as partições LVM, instalamos então o kpartx no modo de rescue.

No entanto, após uns testes, verificamos que mesmo assim não se consegue instalar. Veja os comandos efetuados e o output obtido no "final":

root@rescue:/dev# kpartx -av /dev/VG_XenStorage-2c105b61-f9a5-6dad-058d-657984238414/VHD-d532ae0b-3b5c-49e9-89f7-2e0bcc17468c

root@rescue:/dev# vgscan
Reading all physical volumes. This may take a while...
Found volume group "VG_XenStorage-2c105b61-f9a5-6dad-058d-657984238414" using metadata type lvm2

root@rescue:/dev# vgchange -ay VG_XenStorage-2c105b61-f9a5-6dad-058d-657984238414
4 logical volume(s) in volume group "VG_XenStorage-2c105b61-f9a5-6dad-058d-657984238414" now active

root@rescue:/dev# mount /dev/VG_XenStorage-2c105b61-f9a5-6dad-058d-657984238414/VHD-d532ae0b-3b5c-49e9-89f7-2e0bcc17468c /mnt/
mount: you must specify the filesystem type

________

O estranho será igualmente o output do parted:

root@rescue:~# parted /dev/dm-3 unit gib print
Error: /dev/dm-3: unrecognised disk label

Deveria ser possível de ser montado, mas infelizmente acabamos por não o conseguir, quer sem o kpartx, quer depois com o kpartx. De notar que a partir de agora o kpartx estará incluído no modo de rescue, tendo sido adicionado durante a tarde de hoje.

Quando tal voltar acontecer, basta seguir os passos indicados pelo meu colega, ou seja, pedir no ticket o desbloqueio em modo HD de forma a conseguir verificar o problema, claro está, sempre indicando que não colocará nenhum serviço online até tudo estar devidamente verificado e corrigido.

Com os meus melhores cumprimentos
Ricardo

amsainfor
11-07-12, 13:57
Citação Postado Originalmente por ricardo.durao
Bom dia,

A mensagem poderá ser devido ao facto do Kernel não conhecer o sistema de ficheiros.
Como tal, normalmente, ao usar o comando:

vgchange

E desta feita, o comando específico será:

vgchange -ay

O "a" significa dar a conhecer, o "y" significa "yes". Deixo ainda o manual, caso deseje conhecer esta opção (caso ainda não conheça claro está):

http://linux.die.net/man/8/vgchange

Em rescue esta operação deverá igualmente funcionar sem problemas.

Com os melhores cumprimentos
Ricardo
Obrigado Ricardo.

Tentei também esse comando que coloca todas as partições do "VG" em modo "ACTIVE" mas mesmo assim não resolve.

Depois de resolver o problema do flood UDP 46, que ainda não sei como pois tenho os logs todos normais com o fail2ban a funcionar, irei insistir para que o suporte teste o rescue pro com as partições lvm e me diga como as montar, pois pelo que li durante 1 dia inteiro é necessário nestes casos instalar o "kpartx" para montar as partições LVM, e neste netboot o apt-get não instala nada julgo por permissões de escrita.

Obrigado.

ricardo.durao
11-07-12, 9:36
Bom dia,

A mensagem poderá ser devido ao facto do Kernel não conhecer o sistema de ficheiros.
Como tal, normalmente, ao usar o comando:

vgchange

E desta feita, o comando específico será:

vgchange -ay

O "a" significa dar a conhecer, o "y" significa "yes". Deixo ainda o manual, caso deseje conhecer esta opção (caso ainda não conheça claro está):

http://linux.die.net/man/8/vgchange

Em rescue esta operação deverá igualmente funcionar sem problemas.

Com os melhores cumprimentos
Ricardo

amsainfor
11-07-12, 9:24
Obrigado Ludgero pela sua resposta.

Fiz esse pedido ao suporte ontem às 17H e até hoje não recebi qualquer resposta, assim, procedi eu mesmo dessa forma alterei o arranque do servidor para modo normal e estou analisar a máquina virtual em rescue via xencenter.

Obrigado.

Ludgero
11-07-12, 7:50
Bom dia Amsainfor.

Sugiro que envie uma mensagem (indicando o seu NIC-handle e o servidor dedicado em questão) para o nosso suporte de aconselhamento para obter ajuda.

Em casos em que um servidor dedicado é colocado em rescue por apresentar problemas de segurança, poderá eventualmente solicitar, através do ticket de incidente que o alertou do problema de segurança e alteração do netboot do servidor para rescue, que o servidor seja colocado noutro modo para que possa aceder aos seus dados. Basta que no ticket indique que se compromete em não colocar nenhum serviço online até à deteção e correção do problema.

Não hesite em contactar-nos, usando a sua interface ManagerV3 ou enviando um email para

Cumprimentos

amsainfor
10-07-12, 16:34
Boa tarde a todos,

Preciso da vossa ajuda.
Tenho um servidor dedicado com o xenserver instalado com 3 máquinas virtuais, hoje a OVH procedeu de um modo que nunca pensei ser possível, depois de uma suspeita de hack que tem e deve ser investigada, colocaram-se o servidor inteiro em rescue quando podiam simplesmente bloquear o ip da máquina virtual e avisar o cliente que devia corrigir o problema via xencenter.

Neste momento estou de mãos atadas pois não estou a conseguir montar as partições LVM, já tentei todos os métodos possíveis, segui diversos tutoriais e dá sempre o erro:
"mount: you must specify the filesystem type"

Alguém pode dar uma ajuda?